Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 171 / Bezoekers Vandaag: 7558
Hoogste aantal aktieve gebruikers: 719
Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Op 18 Maart 2019 is Paul Haagsma helaas overleden.

Wij wensen de familie en vrienden sterkte toe!

Lees en of praat hier mee.

Open hier de rouwkaart van Paul Haagsma



 Alle forums
 Koploper
 Beginners
 Automatisch rijden stopt... automatisch
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Auteur Vorig onderwerp Onderwerp Volgend onderwerp  

Stij

Belgium
127 berichten

Geplaatst - 24 mrt 2023 :  16:33:08  Toon profiel  Reageer met citaat
Bizar probleem...

Alles rijdt prima, maar als ik 1 bepaalde loc (66 Lineas) op de baan zet stopt na een tijd het automatisch rijden, alsof je F6 "niet rijden" ingedrukt heb. F8 Automatisch rijden wil dan ook niet meer starten...
Haal ik de loc van de baan... kan ik terug normaal automatisch rijden.

De loc heeft vroeger uren normaal automatisch gereden... maar nu dus niet meer... na een blok of 3 stopt het.

In bijlage m'n DB...


Alvast bedankt om er even naar te kijken.

Stijn

Download Attachment: Mancave_20230324_163048.zip
45,31 KB

Bonaza

Belgium
732 Posts

Geplaatst - 24 mrt 2023 :  19:32:21  Toon profiel  Reageer met citaat
Hallo Stijn,

Kan je wat meer info geven. Ik veronderstel dat de Lineas dan een vaste route rijdt ? En in welk blok stopt hij dan of is dit steeds ergens anders ? Als een loc niet meer verder kan door een bepaalde reden dan stopt het automatisch rijden. (mogelijk geen vervolgblok, kan niet keren, enz..)

Met vriendelije groeten

Marcel
Ga naar bovenaan de pagina

hubertus

Netherlands
1930 Posts

Geplaatst - 24 mrt 2023 :  20:06:45  Toon profiel  Reageer met citaat
Ik zie hier hetzelfde gebeuren, precies wat Stijn beschrijft.
Loc op de baan, gaat ook bij mij na hooguit een paar blokken de baan op niet rijden.
Loc uit blok verwijderen en het automatisch rijden laat zich weer starten. Ik heb een kopie van de loc gemaakt, zelfde effect.
Verder dan de constatering ben ik nog niet gekomen, in elk geval nog geen routes of speciale acties gevonden die dit gedrag kunnen verklaren.
Het gaat trouwens om loc 51-310 LINEAS, adres 66.

Enige wat ik op dit moment kan bedenken (en in de test niet kan nagaan), dat de MFX aanmelding niet goed is gegaan. Maar dat is echt een slag in het duister.

groet, Huub
Ga naar bovenaan de pagina

phdirk

Netherlands
2542 Posts

Geplaatst - 24 mrt 2023 :  21:27:22  Toon profiel  Reageer met citaat
Hallo Stijn,

Ik zelf zoek het meer in de hardware van decoder. Ik denk dat die een beetje van het padje is en na een tijdje de hele zaak op stelten zet.
Jaren geleden ook zoiets gehad. Andere loks stopten en zelfs Koploper en de laptop sloegen op tilt. Als je de lok van de baan haalde, was het probleem over. Toen ik een andere decoder in de lok had gezet was het probleem weg.


Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

hubertus

Netherlands
1930 Posts

Geplaatst - 24 mrt 2023 :  21:40:47  Toon profiel  Reageer met citaat
Dirk,

Ik zie het ook gebeuren, dat is gewoon in de testmodus met de database die Stijn vanmiddag heeft geplaatst. Dan zal het niet aan de decoder liggen.
De MFX suggestie is de aanname dat er ook in Koploper zelf iets gebeurt bij een MFX aanmelding. Of die aanname juist is, weet ik niet. Geen ervaring met dat protocol.

Groet, Huub
Ga naar bovenaan de pagina

keesm

51 Posts

Geplaatst - 25 mrt 2023 :  00:44:37  Toon profiel  Reageer met citaat
Stijn
Als ik de communicatielogging aanzet en kijk naar "diverse foutmeldingen" dan zie ik de volgende mededeling verschijnen:

(v): Fout in logische/speciale akties (AND/OR) en/of telfuncties; automatisch rijden wordt gestopt.

Je zult het dus daar moeten vinden, in routes of akties die uitsluitend voor deze lok bedoeld zijn.



Kees Moerman
Ga naar bovenaan de pagina

Stij

Belgium
127 Posts

Geplaatst - 25 mrt 2023 :  09:23:39  Toon profiel  Reageer met citaat
Hartelijk dank iedereen!

De loc heeft geen vaste routes die aanstaan. Hij volgt wel een paar variabele, maar die worden ook door een ander treintype gevolgd...

Ik ben redelijk wat aan het bijconfigureren... ik zal het daar idd moeten gaan zoeken...

Dom van me niet naar de logging te gaan kijken.

Nogmaals dank!

Stijn
Ga naar bovenaan de pagina

Stij

Belgium
127 Posts

Geplaatst - 25 mrt 2023 :  09:44:02  Toon profiel  Reageer met citaat
Het is toch iets raars... ik heb een back-up van voor m'n nieuwe configuratie terug gezet... en het blijft blokkeren op die locomotief...
Zelfde foutmelding...
Ga naar bovenaan de pagina

hubertus

Netherlands
1930 Posts

Geplaatst - 25 mrt 2023 :  11:08:52  Toon profiel  Reageer met citaat
Met dank aan Kees voor het op het goede spoor zetten.
Het probleem zit in de combinatie van de telfuncties en de logische actie "niet uit klimspiraal vertrekken".
Op basis van wat ik zie (dus niet helemaal zeker), wordt bij een telfunctie de output bepaald op basis van de status van de uitkomst en niet alleen na een wijziging van die status.
Dus als er meer dan 8 treinen in de opgegeven blokken zijn, wil koploper die logische actie altijd waar maken, als er 8 of minder treinen in die opgegeven blokken zijn, wil koploper die logische actie altijd niet waar maken.
De verschillende telfuncties strijden continu om de winst en dat zie je ook terug in de uitkomst logische acties, die bibbert continu zodra het probleem optreedt.
Het heeft dus niks met de 66 te maken, maar dat is toevallig de 9e loc in de blokken buiten de spiraal.Twee van de drie tel functies roepen: "niet uit klimspiraal vertrekken" = waar.
Maar de derde telfunctie zegt: niks ervan, ik zit nog niet aan de 9, "niet uit klimspiraal vertrekken" = niet waar.

Dus per telfunctie een aparte logische actie aanmaken, zou het probleem moeten oplossen.

groet, Huub
Ga naar bovenaan de pagina

Wim Romijn

Netherlands
990 Posts

Geplaatst - 25 mrt 2023 :  11:16:57  Toon profiel  Reageer met citaat
Als je wil weten waar de oorzaak zit dan kan je in het rijwindow van de lok op het tabblad "rijgedrag" met je rechter muis klikken in het witte vlak van de route en kiezen voor verzamelde items.
En daar kan je dan weer kiezen voor bijvoorbeeld het huidige blok.

Dan zie je welke route wat blokkeert.

Mvtgr,

Wim Romijn.
N - DR5000 - loconet
Ga naar bovenaan de pagina

Stij

Belgium
127 Posts

Geplaatst - 25 mrt 2023 :  12:41:52  Toon profiel  Reageer met citaat
Nogmaals bedankt iedereen!

Huub, spot on! Ik heb alle telfuncties verwijderd (heb die eigenlijk toch nog niet nodig) en nu lijkt het te werken. In simulatie dan toch!

Hartelijk dank!!!

Stijn
Ga naar bovenaan de pagina

phdirk

Netherlands
2542 Posts

Geplaatst - 25 mrt 2023 :  15:07:49  Toon profiel  Reageer met citaat
Hi All,

Allen bedankt voor het zoekwerk. Het was dus dit keer geen hardware probleem, maar Koploper dat met zichzelf in de knoop kwam.
Het is goed om te weten dat zulke effecten kunnen optreden en waar je dan kunt zien waar de fout zit.

Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

De treintjesgek

Netherlands
51 Posts

Geplaatst - 05 apr 2023 :  23:24:06  Toon profiel  Reageer met citaat
Hallo Stijn,

Ik heb zojuist een item geplaatst over de decoder LokPilot5 van ESU.
Ik heb o.a. hetzelfde probleem. Als de lok stopt, roep hem op, geef een "Noodstop" en "Go". Dan gaat die weliswaar rijden, maar bij zijn dat soms enkele meters in hetzelfde blok.
Misschien is bij jou hetzelfde probleem als bij mij. Ook ik rijd alleen met variabele routes.

M.v.g.,

Ursmar Ronteltap

Ga naar bovenaan de pagina

Stij

Belgium
127 Posts

Geplaatst - 11 apr 2023 :  08:46:50  Toon profiel  Reageer met citaat
Hallo Usrmar,

neen, bij mij bleek het te maken te hebben met een aantal telfuncties die ik had gedefinieerd in Koploper. Sinds die weg zijn rijdt het vlot.

De Lokpilot was de schuldige niet.

Groetjes,

Stijn
Ga naar bovenaan de pagina
  Vorig onderwerp Onderwerp Volgend onderwerp  
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing © EKweb 2006
Ga naar begin van deze pagina