Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 102 / Bezoekers Vandaag: 3630
Hoogste aantal aktieve gebruikers: 852
Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Op 18 Maart 2019 is Paul Haagsma helaas overleden.

Wij wensen de familie en vrienden sterkte toe!

Lees en of praat hier mee.

Open hier de rouwkaart van Paul Haagsma



 Alle forums
 Koploper
 Gevorderden
 Trein wordt niet gedetecteerd in het blok
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Auteur Vorig onderwerp Onderwerp Volgend onderwerp  

flyerman

Netherlands
98 berichten

Geplaatst - 04 dec 2021 :  23:46:48  Toon profiel  Bezoek de homepagina van flyerman  Reageer met citaat
Ik heb de bouw van de baan wat rails leggen betreft aardig af, alleen een stukje industrie moet nog.

Ik ben nu stukjes aan het test rijden, wanneer ik, database bijgevoegd, automatisch van blok 1 naar blok 3 rij dan wordt de trein niet waargenomen wanneer deze blok 3 inrijdt. Het blok is geel gereserveerd en dat blijft zo. In de log file zie ik dat de inrij bezetmelder (1.13) van blok 3 actief wordt.

Alleen het blok wordt niet rood, het blijft geel.

Ik kan even niet vinden wat er mis is, de database is bijgevoegd, misschien dat iemand de fout kan vinden.

Merci

Download Attachment: StationMartinsdijk_20211204_231556.zip
53,44 KB

hubertus

Netherlands
1650 Posts

Geplaatst - 05 dec 2021 :  10:27:56  Toon profiel  Reageer met citaat
Klinkt als een gemiste bezetmelder.
Is 1.13 ook de bezetmelder die verwacht wordt?
Dit kun je onderin het rijwindow van de locomotief zien.

groet, Huub
Ga naar bovenaan de pagina

flyerman

Netherlands
98 Posts

Geplaatst - 05 dec 2021 :  11:45:18  Toon profiel  Bezoek de homepagina van flyerman  Reageer met citaat
Daar moet ik vanavond even naar kijken, zoals gezegd wordt de melder 1.13 wel gedetecteerd volgens de log file.

Het komt momenteel in meer blokken voor, ook van 2 naar 103 bv. 103 blijft geel en de trein remt in blok 2 ook niet af naar de wisselstraat snelheid. Een rijdt dan volgas door 103 heen.

Bewerkt door flyerman op 05 dec 2021 11:49:31
Ga naar bovenaan de pagina

hubertus

Netherlands
1650 Posts

Geplaatst - 05 dec 2021 :  12:42:38  Toon profiel  Reageer met citaat
Als melder 1.13 niet de melder is die koploper verwacht, is het niet zo interessant of deze doorkomt.
Ik vermoed dat je het probleem in een eerder blok moet zoeken.

groet, Huub
Ga naar bovenaan de pagina

RdJ

Netherlands
15 Posts

Geplaatst - 05 dec 2021 :  13:12:14  Toon profiel  Reageer met citaat
In je database zie ik bij de eigenschappen van de blokken geen vinkjes staan in het onderste gedeelte: Bezet bij ....
Hier moet je nog bezetmelders aanvinken waarbij dat betreffende blok als bezet getoond moet worden. Zie het screenshot

Weet niet of dat het probleem helemaal oplost, maar denk dat je dit in ieder geval bij elk blok nog wel moet aanvinken.

Download Attachment: Bezetmeldingen.JPG
75,61 KB

Groeten,
Ron
Ga naar bovenaan de pagina

flyerman

Netherlands
98 Posts

Geplaatst - 05 dec 2021 :  13:21:21  Toon profiel  Bezoek de homepagina van flyerman  Reageer met citaat
Naar mijn idee hoeft dat niet, dat heb ik in de blokken waar het goed werkt ook niet. Maar ik kan natuurlijk eens kijken of dat verandering brengt.
Ga naar bovenaan de pagina

RdJ

Netherlands
15 Posts

Geplaatst - 05 dec 2021 :  13:45:22  Toon profiel  Reageer met citaat
Begrijp uit de help dat dat inderdaad niet nodig is, heb ik altijd wel ingevuld, maar is blijkbaar bedoeld voor als je wagons achterlaat in een blok zodat dat blok nog als bezet getoond wordt. Weer wat geleerd
Ga naar bovenaan de pagina

flyerman

Netherlands
98 Posts

Geplaatst - 05 dec 2021 :  15:10:50  Toon profiel  Bezoek de homepagina van flyerman  Reageer met citaat
Om even antwoord te geven op Huub zijn opmerking. De bezetmelder 1.13 wordt als verwachte bezetmelder weergegeven, wordt ook door Koploper gedetecteerd volgens de logging, maar licht niet op wanneer de trein het blok 3 binnenrijdt.
Ga naar bovenaan de pagina

hubertus

Netherlands
1650 Posts

Geplaatst - 05 dec 2021 :  15:38:27  Toon profiel  Reageer met citaat
Ik heb het in je database nagespeeld en daar werkt het zoals verwacht. Zodra ik op 1.13 een bezetmelding geef, wordt blok 3 bezet. De trein krijgt dan wel direct een noodstop, maar dat heeft ongetwijfeld te maken met de controle (op de wisselstand?) die je uitvoert in de logische en speciale acties.

groet, Huub
Ga naar bovenaan de pagina

flyerman

Netherlands
98 Posts

Geplaatst - 05 dec 2021 :  15:52:19  Toon profiel  Bezoek de homepagina van flyerman  Reageer met citaat
Ja klopt, die controle werkt niet in de simulatie.

Je kan de bezetmelder actief zetten en dan een bezetmelding genereren, maar wanneer het rijdt, ook met simulatie, dan werkt die bezetmelding niet.

Ik heb de vinkjes aangevinkt van 1.13 en 6.01 voor "bezet bij". Wanneer ik een wagon op 1.13 zet wordt het blok blauw maar de bezetmelder die 1.13 weergeeft licht niet op.

Bewerkt door flyerman op 05 dec 2021 17:26:09
Ga naar bovenaan de pagina

flyerman

Netherlands
98 Posts

Geplaatst - 05 dec 2021 :  22:35:57  Toon profiel  Bezoek de homepagina van flyerman  Reageer met citaat
Ik heb even twee bezetmelders omgedraaid, 1.13 is 1.14 geworden en vice versa.

Nu werkt het in blok 3, Althans ik heb even test gereden en het ging goed. Moet nu een week werken dus even niet thuis, maar volgende week gaan we door.

Ik denk dat er even een hickup zat en dat het wisselen van de melders en het opslaan ervan weer hersteld is. We zullen zien.

Zoals gezegd, volgende week verder.
Ga naar bovenaan de pagina
  Vorig onderwerp Onderwerp Volgend onderwerp  
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing © EKweb 2006
Ga naar begin van deze pagina