Print deze pagina | Sluit het venster

LokPilot 5 DCC met Koploper

Geprint door: Koploperforum Digitale Treinbesturing
Webadres onderwerp: https://www.koploperforum.nl/topic.asp?TOPIC_ID=7058
Geprint op: 01 mrt 2024

Onderwerp:


Auteur onderwerp: Hennie Klaassen
Onderwerp: LokPilot 5 DCC met Koploper
Geplaatst op: 08 aug 2023 21:01:59
Bericht:

Beste Forumleden,

Ik heb via mijn ESU Lokprogammer een LokPilot 5 DCC geprogrammeerd met een ontkoppelingswals op F9 met AUX7 en op F10 met AUX8. Met op de AUX7 en AUX8 ieder een krois koppeling.
Nu werkt de ontkoppelingswals goed als ik die gebruik in de Drivers"cab van de ESU programmer,
ook met de IntelliboxII werkt deze met alle anderen instellingen die ik in de decoder heb ingezet.

Als ik de instelling in koploper in de rijwindow gebruik, en ik F9 of F10 een (Vinkje bij aan zet) dan gaan onder F5, F6, F7, F8 de lichten uit maar de ontkoppelingswals word wel gedaan?
En als ik dan in koploper in het rijwindow bij F8 even de Vinkje weg doe dan gaan al deze lichten weer aan, dit kan met een van de anderen functies F5, F6 of F7 ook.

Als ik nu met de koploper ingeschakeld en de IntelliboxII deze F9 of F10 indruk gaan nu ook de lichten onder F5, F6, F7, F8 uit en ontkoppelingswals word wel gedaan, ook hier als ik de F8 of een van de andere F5, F6, F7 indruk op de IntelliboxII gaan de lichten weer aan.

Onder F5 zit AUX3 roodsluitlicht voor. Onder F6 zit AUX4 roodsluitlicht achter. Onder F7 zit AUX5 zwaailicht voor. Onder F8 zit AUX6 zwaailicht achter.

Functie onder F0, F1, F2 blijven wel branden. Functie F0 voorlicht wit en achterlicht wit. F1 AUX1 rangeerlicht voor en achter. F2 AUX2 cabine verlichting.

Iemand een suggestie om dit probleem op te lossen.
M.v.g, Hennie.


HKL

Reacties:


Reageer op auteur: Ben
Gereageerd: 09 aug 2023 11:12:52
Bericht:

Een Krois koppeling stuur je aan met een knop in het rijwindow, niet met aan/uit. Dit stel je in bij onderhouden lokomotieven en functies. De tijdsduur dat de knop actief is stel je daar ook in. Die duur moet net iets langer zijn dan de tijd van de gehele koppelingswals in de ESU decoder.

Gr, Ben.


Reageer op auteur: Hennie Klaassen
Gereageerd: 09 aug 2023 19:01:23
Bericht:

Hoi Ben,

Ik heb mij instelling aangepast na de info die je mij gaf, die knop werkt nu handig.
Instelling op 6 seconden gezet werkt prima.
Alleen is het probleem nog niet opgelost en reageert nog hetzelfde, ook op de IntelliboxII geen verschil.

Groet Hennie.






HKL


Reageer op auteur: phdirk
Gereageerd: 09 aug 2023 22:14:12
Bericht:

Hallo Hennie,

Mijn ervaring is dat LokPilots 5 wel eens raar willen reageren. In sommige locs heb ik ze al vervangen door Zimo's die wel goed werken.
In mijn Hippel 657 heb ik wel een LokPilot 5 zitten, omdat ik in die loc heel veel functies heb zitten. Zowel op het TwinCenter, als in Koploper doen alle functies het goed.
Hierbij het overzicht van mijn instellingen, mogelijk heb je er wat aan.


Download Attachment: Hippel657.pdf
740,27 KB



Met beste groeten
Dirk
HO=TC


Reageer op auteur: Hennie Klaassen
Gereageerd: 10 aug 2023 18:59:29
Bericht:

Hallo Dirk,

Dankje voor de info, ik ga er dit weekend mee aan de slag.
En laat weten of er vorderingen zijn of niet.

M.v.g, Hennie

HKL


Reageer op auteur: Ben
Gereageerd: 11 aug 2023 08:03:05
Bericht:

quote:
Oorspronkelijk geplaatst door phdirk

Mijn ervaring is dat LokPilots 5 wel eens raar willen reageren.

Hierbij het overzicht van mijn instellingen, mogelijk heb je er wat aan.




Je hebt 2 digitale koppelingen op één uitgang gezet, waarom is dat?

En what about LokPilot 5 die wel eens slecht reageren, waar gaat dat over?

@Hennie: post eens je Esu LokProgrammer bestand, wellicht helpt dat.

Gr, Ben.


Reageer op auteur: Hennie Klaassen
Gereageerd: 11 aug 2023 20:09:48
Bericht:

Hoi Ben,

Ik heb mijn kroiskoppeling op twee functies zitten F9 met AUX7 en F10 met AUX8.
Hierbij mijn bestand.

Download Attachment: Klaassen.zip
103,86 KB


Groet Hennie.

HKL


Reageer op auteur: phdirk
Gereageerd: 11 aug 2023 21:01:20
Bericht:

Ben,

Ik zet altijd mijn Kroiskoppelingen op één uitgang. Vroeger had je ook niet veel keus als je nog wat andere dingen wilde aansluiten, zoals een zwaailicht. Nu je meer mogelijkheden hebt doe ik dat nog steeds.

Ik heb de verschijnselen die Hennie beschrijft bij de LokPilot 5 ook wel langs zien komen. Op het TwinCenter werkt alles prima, maar in Koploper gebeuren rare dingen, lampen die aan- en uitgaan, de lok die stopt en dergelijke. Dat waren locs van treinenvrienden en kennelijk gaat het op de thuisbaan wel goed.

Loks met een LokPilot 5 slaan in bepaalde blokken van mijn baan op hol. Ze zijn dan alleen te stoppen door de spanning van de baan te halen. Daarna werken alle functies prima, maar rijden doen ze niet meer. Dat gebeurt pas weer als ze even op het programmeerspoor hebben gestaan. Ik heb dit ook aan ESU voorgelegd, maar die weten er ook geen antwoord op.
In één loc, die ik open heb liggen, heb ik de decoder nu ingepakt in aluminiumfolie en nu lijkt ze netjes te rijden. Alle andere decoders (LokPilot 3 en 4, Zimo, Lenz) werken op de hele baan zonder problemen.
Ik heb ook de betreffende bezetmelder vervangen, maar dat bood evenmin soelaas.

Met beste groeten
Dirk
HO=TC


Reageer op auteur: hubertus
Gereageerd: 12 aug 2023 08:46:58
Bericht:

Hennie,

Begrijp ik het goed dat het direct op de IB wel werkt en aangestuurd uit koploper niet?
Plaats dan even je database.

@ Dirk
Je geeft regelmatig aan problemen te hebben met de Lopi 5 en even zo vaak moet ik concluderen dat ik die problemen niet herken.
Weet je zeker dat het bij jou geen brakke Twincenter en/of verbinding met de pc is? Of dat het gewoon op een andere manier aan jouw baan ligt. Heb je al eens geprobeerd met een andere TC of een intellibox?

groet, Huub


Reageer op auteur: Hennie Klaassen
Gereageerd: 12 aug 2023 09:41:17
Bericht:

Hubertus,

Mijn Intellibox en de ESU programmer hebben geen probleem met de instellingen van de decoder en werkt op alle twee goed.
Als ik op koploper deze gebruik dan gaat het fout, als ik de F10 indruk gaan de lichten van F5,F6,F7,F8 uit.
Ook op de intellibox gaat het dan fout.

Hierbij mijn bestand van koploper.

Download Attachment: bovenbouwtest_20230811_212902.zip
53,09 KB


Reageer op auteur: hubertus
Gereageerd: 12 aug 2023 09:48:27
Bericht:

Om welke loc gaat het, 2275?


Reageer op auteur: Hennie Klaassen
Gereageerd: 12 aug 2023 10:13:32
Bericht:

Ja het gaat om de 2275.
Ik heb in deze lok een Ulhenbrock decoder gehad en een functie decoder onder decoder nr 75
Maar kreeg mijn kap toen niet dicht op de lok, vandaar de ESU geplaatst met lang adres 2275.
Kan het zijn dat koploper ergens deze info vast houd? en daar om dit probleem zich voor doet.

M.v.g, Hennie.


Reageer op auteur: hubertus
Gereageerd: 12 aug 2023 10:45:45
Bericht:

In de test gaat het goed, de juiste opdrachten worden uitgestuurd door Koploper.
Je kunt het volgende proberen, geen garantie dat het helpt.
Bij instellingen per database -> Algemeen-1 -> klik op "Speciaal digitaal systeem"
Experimenteer met de opties bij "Afhandelen locomotief functies". Dus opsturen formaat aanpassen naar Intellibox II en/of vinkje bij Opsturen beperken.

groet, Huub


Reageer op auteur: Hennie Klaassen
Gereageerd: 12 aug 2023 11:27:22
Bericht:

Huub,

Ik heb de test uitgevoerd, in koploper is er geen verschil.
In IBII als ik daar met F5,F6,F7,F8 en dan de F9 of F10 indruk gaan de functies uit de Vinken gaan dan ook weg.
Deze kon ik eerst nog terug halen met een druk op 1 van de 4 functie knoppen, dat werkt dan niet en moet ze zelf weer aanzetten.

M.v.g, Hennie.


Reageer op auteur: Ben
Gereageerd: 12 aug 2023 11:53:42
Bericht:

quote:
Oorspronkelijk geplaatst door Hennie Klaassen

Hoi Ben,

Ik heb mijn kroiskoppeling op twee functies zitten F9 met AUX7 en F10 met AUX8.
Hierbij mijn bestand.




Wat ik zie is dat je AUX7 en AUX8 waar de Krois koppelingen aan hangen hebt geconfigureerd als "dimmable headlight", eigenlijk moet dat "coupler" zijn.

Misschien ver gezocht maar mogelijk heeft dit effect op de andere uitgangen als je de ontkoppelwals afspeelt.

Gr, Ben.


Reageer op auteur: Hennie Klaassen
Gereageerd: 12 aug 2023 12:16:07
Bericht:

Ben,

Alle suggesties zijn welkom, ik heb de instelling aangepast naar coupler maar resultaat is nog hetzelfde.

Huub,

Deze teks kun je vergeten:
In IBII als ik daar met F5,F6,F7,F8 en dan de F9 of F10 indruk gaan de functies uit de Vinken gaan dan ook weg.
Deze kon ik eerst nog terug halen met een druk op 1 van de 4 functie knoppen, dat werkt dan niet en moet ze zelf weer aanzetten.

Ik heb de instellingen in koploper terug gezet, en zie nu dat IBII al zo reageerde.
Anders zet ik je op het verkeerde spoor om het probleem optelossen.



M.v.g, Hennie


Reageer op auteur: hubertus
Gereageerd: 12 aug 2023 12:45:01
Bericht:

Samenvattend:
- als je de loc puur via de IB bedient, doen de functies het zoals je wilt. Dus als F5 t/m F8 aan zijn, dan blijven die aan als je F9 of F10 bedient
- als je hetzelfde doet via koploper, gaan F5 t/m F8 uit op de IB, als je F9 of F10 bedient. Als je daarna een van de functies F5 t/m F8 even uitvinkt in Koploper en daarna weer aanvinkt, gaan alle vier die functies op de IB weer aan.

Zou je eens de communicatielogging eens kunnen laten meelopen als je de handelingen in Koploper uitvoert?
Filter op 2275 en een vinkje bij communicatie locomotieven.
Wat krijg je dan te zien als logging?

groet, Huub


Reageer op auteur: phdirk
Gereageerd: 12 aug 2023 16:16:27
Bericht:

Huub,

Het enige dat ik nog niet heb vervangen is het TwinCenter. Dat zou ik nog eens kunnen doen. Overigens zie ik wel dat Koploper de opdrachten netjes verstuurt en dat het TwinCenter die netjes doorgeeft. Als ik alleen met het TwinCenter rijdt, gehoorzamen de locs prima.
Zelf houd ik het meer op een of ander veld dat de zaak verstoort. De betreffende blokken zitten wel in de buurt van de plaats waar de trafo's en dergelijke onder de baan hangen. Dat het aanbrengen van een kooi van Faraday (aluminiumfolie) het probleem lijkt te verhelpen, wijst daar ook op.

Met beste groeten
Dirk
HO=TC


Reageer op auteur: Hennie Klaassen
Gereageerd: 12 aug 2023 19:24:44
Bericht:

Hallo Huub,

Het was even stoeien met het bestand en in koploper om dit voor elkaar te krijgen, hier had ik nog niet mee gewerkt.
Ik hoop dat dit is waar je om vroeg, en anders hoor ik het wel.

Download Attachment: bovenbouwtest_20230812_190911.txt
1,23 KB

M.v.g, Hennie


Reageer op auteur: hubertus
Gereageerd: 12 aug 2023 19:43:26
Bericht:

Dit is inderdaad wat ik vroeg.
Koploper probeert in elk geval de goede opdrachten te versturen.
Omdat het direct vanaf de IB wel goed gaat, lijkt het er sterk op dat de oorzaak tussen PC en IB zit.

Voor wat het waard is, want elke situatie is anders, ik heb zelf een IB-2 en daar in het begin veel problemen met de communicatie gehad. Opdrachten kwamen niet of te laat aan.
Omdat ik nog een losse loconet-interface had uit mijn IB-1 tijd, ben ik die gaan gebruiken en daarmee waren de problemen verholpen.
Mijn vermoeden was destijds dat de door mij gebruikte USB-kabel te lang was. Maar omdat het werkte met de externe interface, me er verder niet meer in verdiept.


Reageer op auteur: Hennie Klaassen
Gereageerd: 12 aug 2023 20:32:00
Bericht:

Hallo Huub,

Ik heb hier het nog een communicatie logging bestand maar dan met bewerking via Koploper en via de IBII.


Download Attachment: bovenbouwtest_20230812_193025.txt
2,8 KB

M.v.g, Hennie


Reageer op auteur: Hennie Klaassen
Gereageerd: 13 aug 2023 13:32:43
Bericht:

Huub,

Ik heb ook nog een Loconet-interface van Rosoft liggen en ga deze er ook tussen zetten.
Maar ik heb geen handleiding hoe ik deze tussen de IBII moet zetten, heb jij die wel?
Vraag me ook af aan welke kant de stekker van de loconet aansluiting moet in pluggen links of rechts van de led's.
( Led's geel boven groen onder )
Als dit niet werkt, neem ik aan dat ik weer zo terug kan naar de oude stand van nu.

Ik ga hier vanavond mee aan de gaan.





M.v.g, Hennie


Reageer op auteur: hubertus
Gereageerd: 13 aug 2023 17:02:43
Bericht:

Ik neem aan dat je de USB-versie hebt?

Het maakt niet uit welke plug je gebruikt.
Je sluit de interface aan op de Loconet T uitgang van de IB, de USB-kabel tussen IB en PC verwijder je.

Ik heb zelf de RS232 versie, die werkt met een Baudrate van 19200. Ik dacht de USB versie ook, maar niet helemaal zeker. In elk geval zowel op de IB als in Koploper dan de baudrate aanpassen.

Je kunt altijd weer terug naar de oude situatie, maar maak voor de zekerheid wel eerst een backup.

groet, Huub


Reageer op auteur: Wim Romijn
Gereageerd: 13 aug 2023 17:23:05
Bericht:

Loconet werkt met 19200 baud, sneller heeft geen nut.

Mvtgr,

Wim Romijn.
N - YaMoRc YD7001 - loconet


Reageer op auteur: Hennie Klaassen
Gereageerd: 13 aug 2023 19:18:55
Bericht:



Ik heb de Loconet-Inteface er tussen geplaatst en getest, maar het resultaat is het zelfde als alleen met de IBII.
Wat ik nu ga proberen is dat ik de AUX7 en AUX8 op AUX1 en AUX2 ga omzetten op de loc.
Als ik de koppelwals uitvoer dan blijven de lichten branden op AUX1 en AUX2.
Je weet maar nooit!






M.v.g, Hennie


Reageer op auteur: Hennie Klaassen
Gereageerd: 14 aug 2023 20:40:28
Bericht:


Gisteren de Functies om gesoldeerd van:
F9 AUX7 naar F1 AUX1 ontkoppelwals voor.
F10 AUX8 naar F2 AUX2. ontkoppelwals achter.
en de ander net omgekeerd:
F1 AUX1 naar F9 AUX7 Rangeer licht.
F2 AUX2 naar F10 AUX8 Cabine verlichting.
Een vandaag de decoder een reset gegeven op CV 8.
Eerst ging het niet, toen via een update in de ESU programmer kon ik hem toch terug zetten.
Nieuw bestand gemaakt in ESU Locprogrammer met loc nr 2273 en alle gegevens er ingezet.
Ook in Koploper een nieuwe loc aangemaakt met loc nr 2273.
En ook daar de juiste gegevens ingevoerd.
En het werkt nu in koploper en ook in de IBII.
Als ik F9 AUX7 of F10 AUX8 ga gebruiken moet ik deze wel eerst aanzetten voor dat ik de andere functies gebruik.
Doe ik dit niet dan gaan de ander functies uit, dus zit er nog iets niet goed denk ik in AUX7 en AUX8.
Een heel verhaal maar werkt het nu.

Dirk,

Ter info, in jou ESU locprogrammer file zag ik geen cv's staan, ik weet niet of je dat weet maar deze kun je zichtbaar maken via:
Tools > Change program een Vink zetten bij: Show CV numbers en dan Save change. en eventueel programma afsluiten en weer opstarten.


M.v.g, Hennie


Koploperforum Digitale Treinbesturing : https://www.koploperforum.nl/

© EKweb 2006

Sluit venster