Print deze pagina | Sluit het venster

Intellibox: locs blijven stilstaan na noodstop

Geprint door: Koploperforum Digitale Treinbesturing
Webadres onderwerp: https://www.koploperforum.nl/topic.asp?TOPIC_ID=6980
Geprint op: 13 apr 2024

Onderwerp:


Auteur onderwerp: mhlvdijk
Onderwerp: Intellibox: locs blijven stilstaan na noodstop
Geplaatst op: 07 feb 2023 10:00:23
Bericht:

Beste mensen,

Heb een wellicht wat apart probleem.
Bij mijn Intellibox 1 had ik op een gegeven moment diverse problemen en dus vervangen door een Intellibox 2. Echter één probleem is blijven bestaan. Toeval kan bijna niet, dus ik zal wat verkeerd doen. Het volgende:

Na een noodstop gebeurt het volgende:
1. Rijdende treinen rijden vaak weer verder (maar niet altijd)
2. Stilstaande treinen komen (indien deze zouden moeten gaan rijden) niet meer op gang. De snelheid blijft 0. Ook de frontverlichting blijft uit (bij mij standaard uit in het schaduwstation).

Ik heb in de log gekeken van Koploper: signaal snelheid en licht wordt weldegelijk gestuurd. Maar als je de loc dan selecteerd op de IB2 dan staat de snelheid nog op 0.

Maar.... Als ik - terwijl Koploper de loc in beweging zet - de loc selecteer op de IB2 komt er wel beweging in de loc en gaat de frontverlichting ook netjes branden

Indien er geen snelheid meer verzonden wordt (en de snelheid op de IB2 dus nog steeds 0 is en blijft) zet ik de trein handmatig in beweging met een bepaalde snelheid. Bij een volgend blok pakt Koploper de bediening weer over en zie ik de snelheid op de IB aangepast worden en gaat het licht ook weer aan.

Het is een vervelend probleem, temeer ik een stuk of 30 treinen op de baan heb staan. Elke trein moet ik dan handmatig opstarten als deze door Koploper in beweging wordt gezet. Dat is gewoon niet te doen.

Een oplossing heb ik niet kunnen vinden, maar wellicht gaat hier bij iemand het licht branden ;-)

Bedankt vast!

Michiel

Reacties:


Reageer op auteur: JPJ
Gereageerd: 07 feb 2023 10:37:37
Bericht:

Hallo Michiel,

Is je voeding wel zwaar genoeg ?
Ik lees dat je met 30 treinen rijd.

Jos


Reageer op auteur: mhlvdijk
Gereageerd: 07 feb 2023 12:19:32
Bericht:

Dag Jos,

Zeker! Ze rijden niet allemaal tegelijkertijd en daarnaast heb ik 6 boostersin bedrijf. Dat zit m.i wel goed ;)
Groet,
Michiel


Reageer op auteur: Bonaza
Gereageerd: 07 feb 2023 15:16:32
Bericht:

Hallo Michiel,

Als ik het goed begrijp is het probleem dat je de locs na een noodstop terug 1 voor 1 moet opstarten. Als na het opheffen van de noodstop in het window "Overzicht locomotieven" er terug groene go's achter je locs staan. Dan moet je boven het bovenste groene bolletje op het middenste vierkantje drukken, hier kan je alle treinen terug opstarten. (zien bijvoegsel)

Groeten

Marcel

Download Attachment: Noodstop.jpg
107,08 KB


Reageer op auteur: mhlvdijk
Gereageerd: 07 feb 2023 16:31:52
Bericht:

Helaas, dat is het probleem niet. Ze worden aangestuurd door Koploper om te gaan rijden, volgens log worden er gegevens verzonden, maar de trein blijft op zn plek staan.
Pas als ik via de intellibox zelf ingrijpt krijg ik ze van hun plek.

Het gaat dus ergens om de communicatie tussen het programma en de hardware.


Reageer op auteur: Bonaza
Gereageerd: 07 feb 2023 17:26:02
Bericht:

Michiel,

Rijdt je met loconet en hoe is je PC verbonden met de Intellibox met een USB kabel ?

grts

Marcel


Reageer op auteur: phdirk
Gereageerd: 07 feb 2023 17:28:51
Bericht:

Hallo Michiel,

Dat is een vervelend en ook lastig probleem. Ik ken een aantal mensen die met de combinatie IBII en Koploper rijden, maar dit verschijnsel heb ik nog niet gezien.
Wat wel eens gebeurt als Koploper niet juist wordt afgesloten, is dat alle loks 'dood' staan en dus de aangeschakelde functies niet aanschakelen als Koploper wordt gestart. De functies staan dan ook echt uit in Koploper. De treinen beginnen dan wel te rijden als Koploper een rij-opdracht geeft.
Ik vermoed toch een probleem in de communicatie tussen de PC en de IBII. Mogelijk functioneert een deel van Koploper niet goed en worden de opdrachten niet goed doorgegeven. Wellicht is het de moeite waard om Koploper eens opnieuw te installeren.
Of als je die mogelijkheid hebt eens een andere PC proberen.
Dan kun je in ieder geval lokaliseren waar het probleem zit.


Met beste groeten
Dirk
HO=TC


Reageer op auteur: Bonaza
Gereageerd: 07 feb 2023 18:15:51
Bericht:

Hey Michiel,

In aansluiting op wat Dirk bemerkt probeer ook eens een andere USB kabel. Het falen hiervan is reeds verscheidene malen voor gekomen op dit forum.

grts

Marcel


Reageer op auteur: hubertus
Gereageerd: 07 feb 2023 19:22:27
Bericht:

Het effect op zich herken ik en bij mij was het terug te voeren op de (vermoedelijk te lange) USB-verbinding tussen PC en IB.
Ik ben weer teruggegaan naar de loconet-interface die ik nog had van de IB1. Omdat dat werkte, me er verder niet meer in verdiept. Maar ik vermoed dat er na het opheffen van de noodstop gewoon teveel communicatie was, waardoor de USB het niet aan kon.
De vraag is dus inderdaad, hoe is jouw verbinding?

groet, Huub


Reageer op auteur: mhlvdijk
Gereageerd: 07 feb 2023 20:02:45
Bericht:

Dank jullie allemaal dat jullie zo meedenken.

Ik heb mijn IB2 inderdaad aan de (standaard??) witte USB kabel hangen en die aangesloten op een USB poort.

Ik had zelf natuurlijk kunnen bedenken dat ik even een andere PC moest proberen, maar dat deed ik niet. Dan is zo'n forum toch handig. Nu nog een andere PC ;-)

Ik ga m ook weer proberen aan Loconet te hangen. Maar dat had ik bewust niet gedaan, omdat ik via de USB 115.200 baud verbinding heb en via Loconet kastje van Rosoft 9.600 baud. Ik dacht een voordeel te ondervinden van die USB kabel, maar gaat Loconet geen verschil maken in de snelheid van signalen?


Reageer op auteur: hubertus
Gereageerd: 07 feb 2023 20:14:07
Bericht:

Bij mijn kastje van Rosoft heb ik een baudrate van 19200 ingesteld.
Misschien dat er meerdere versies zijn.

Ik zou zeggen, probeer dat ding gewoon. Als het werkt, dan werkt het en anders zoeken we wel weer verder.
Hier draait het daarmee in elk geval zonder problemen en er is bij mij best wel wat communicatie.

groet, Huub


Reageer op auteur: mhlvdijk
Gereageerd: 07 feb 2023 20:26:48
Bericht:

Ga 'm weer aansturen via Loconet. Ik meld mij later weer als ik nieuwe resultaten heb. Dat zal niet direct vanavond of morgenavond zijn denk ik ;-)


Reageer op auteur: phdirk
Gereageerd: 08 feb 2023 22:18:39
Bericht:

Hallo Michiel,

Ik gebruik ook de Loconetinterface van Wim en die staat ook op een baudrate van 19200. Dat moet dus kunnen denk ik

Met beste groeten
Dirk
HO=TC


Reageer op auteur: Wim Ros
Gereageerd: 12 feb 2023 00:53:53
Bericht:

Loconet werkt zelf met een baudrate van ongeveer 16457 bps,

De Loconet-IF werkt op 19200bps, dus sneller heeft niet zoveel nut het zal toch niet sneller dan 16457 gaan.

NETWORK Timing:
LocoNetÒ data is sent in normal ASYNCHRONOUS format using 1 START bit, 8 DATA bits
and 1 STOP bit. The 8 bit data is transmitted LSB first. The bit times are 60.0 uSecs or 16.66 KBaud +/-
1.5%. A PC serial "COM" device can use the convenient rate of 16.457 KBaud. This corresponds to a
Divisor of 07 for the standard NS8250 UART chip or equivalent used by most compatibles. Bytes may be
transmitted "back-to-back", with a Start bit immediately following the Stop bit of the previous character.

Mvg
Wim.



Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus


Reageer op auteur: mhlvdijk
Gereageerd: 12 feb 2023 10:41:01
Bericht:

Dank Wim voor de verduidelijking!

Op dit moment nog niet veel gereden, maar vooralsnog wel zonder het bekende probleem. Gaat zeker nog verder vervolgd worden.


Koploperforum Digitale Treinbesturing : https://www.koploperforum.nl/

© EKweb 2006

Sluit venster