Print deze pagina | Sluit het venster

Wissel luistert niet Ecos/Koploper combinatie

Geprint door: Koploperforum Digitale Treinbesturing
Webadres onderwerp: https://www.koploperforum.nl/topic.asp?TOPIC_ID=6325
Geprint op: 25 aug 2019

Onderwerp:


Auteur onderwerp: Leendert
Onderwerp: Wissel luistert niet Ecos/Koploper combinatie
Geplaatst op: 17 jun 2019 08:28:11
Bericht:

Ik heb een pittig ‘foutje’ gehad met de combinatie Koploper/Ecos. Hier even delen wat het probleem was en ook wat de bypass is.

Symptoom
Op de ECOS zijn 3 van de 4 wissels (uit steeds een blokje van 4) op de ECOS wel te schakelen, maar vanuit Koploper niet.

Hoe ziet de instellen er uit
De ECOS is standaard ingesteld op Motorola formaat voor de wissels (daar heb ik tenslotte de meeste decoders van) en voor de ‘uitzonderingen’, die naar DCC luisteren, maak ik wissels aan op de ECOS.

Waar ging het mis
Het ging alleen mis op die decoders waar zowel wisselaandrijvingen als bv een ontkoppelrail aan zit. In de Ecos is prima in te stellen en met Koploper is de ontkoppelrail ook prima te bedienen. Maar de 3 overige wissels zwijgen in alle talen als ze door Koploper bediend worden.

Wat blijkt
Korte versie van een lang verhaal (met veel debuggen en logs napluizen, zowel in Koploper als in de ECOS): tijdens het initialiseren van Koploper, gaat deze in dialoog en wisselt uit wat er over en weer beschikbaar is en nodig is. Dat geldt (en is al vaker ook op dit form ter sprake gekomen) voor de locomotieven, waarbij je een goede volgorde aan moet houden omdat anders de synchronisatie weg is, maar – zo blijkt – ook voor wissels. Het is per ‘blokje van vier’ of een K84 of een K83 (de variant die bistabiel is, of monostabiel). Bij de mengvorm gaat het fout.

Remedie
Is duidelijk: niet mengen, dan gaat het goed. Dus op de blokken van 4 adressen of alleen K84 of K83 achtige functies.

Groet,
Leendert


Koploperforum Digitale Treinbesturing : https://www.koploperforum.nl/

© EKweb 2006

Sluit venster