Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 56 / Bezoekers Vandaag: 3642
Hoogste aantal aktieve gebruikers: 302
Google


Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Modelspoorwijzer.net

 Alle forums
 Koploper
 Beginners
 F2 aansturen lukt niet bij automatisch rijden
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Auteur Vorig onderwerp Onderwerp Volgend onderwerp  

Dieky

Netherlands
104 berichten

Geplaatst - 20 jan 2016 :  14:16:18  Toon profiel  Bezoek de homepagina van Dieky  Reageer met citaat
In mijn pendel DB628 heb ik een esu decoder ingebouwd met 2 functies.
Dit zijn de binnenverlichtingen in de beide helften van de 628.
F1 stuurt 1 kant aan. F2 de andere kant.
Daarnaast stuurt F de verlichting aan.

Bij automatisch rijden heb ik ingesteld dat alle verlichting aangaat zodra koploper wil gaan rijden (gewenst)en dat de binnen verlichting na 6 seconden(F1) en 4 seconden (F2) uit gaan.

Dit werkt op de een of andere manier niet. In de communicatielogging staat wel dat het aangestuurd wordt, maar de verlichting (F, F1 en F2) doen niets. Heel af en toe gaat alles onderweg aan, maar dat is zeldzaam.
Als ik de F2 weghaal bij "functies uitgebeid" werkt alles keurig. zodra ik de F2 er weer bijzet is het probleem er weer.

Meine





Download Attachment: Knipsel.JPG
103,99 KB

Download Attachment: Asserhalte.bck
126,37 KB

Website: http://www.EenOpZevenEnTachtig.nl

phdirk

Netherlands
1762 Posts

Geplaatst - 20 jan 2016 :  15:30:17  Toon profiel  Reageer met citaat
Hallo Meine,

Even een schot voor de boeg op basis van je screenshot; ik heb je database nog niet bestudeerd. Je hebt het aan- en uitschakelen van de functies nu ingesteld voor ieder blok. Dat betekent dat de trein in ieder blok de verlichting aan en uit wil schakelen. Met de vertraging die je daarbij hebt opgegeven kan het gebeuren dat de trein niet aan aanschakelen toekomt.
Ik denk dat het wel gaat werken als je het aan en uitschakelen aan specifieke blokken toekent, bijvoorbeeld de keerblokken van je pendelroute. Zo heb ik het ook in mijn treinen geregeld. Als ze worden afgerangeerd gaat in het opstelspoor na een aantal seconden de binnenverlichting uit. Als de trein weer klaarstaat om te vertrekken wordt de verlichting weer aangeschakeld.


Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

Dieky

Netherlands
104 Posts

Geplaatst - 20 jan 2016 :  16:18:53  Toon profiel  Bezoek de homepagina van Dieky  Reageer met citaat
Dick,

Zo te zien was dat het probleem.
Ik heb het aangepast en het werkt zoals ik het verwacht.

Bedankt!

Meine

Website: http://www.EenOpZevenEnTachtig.nl
Ga naar bovenaan de pagina

Dieky

Netherlands
104 Posts

Geplaatst - 20 jan 2016 :  21:05:45  Toon profiel  Bezoek de homepagina van Dieky  Reageer met citaat
Toch nog niet opgelost.

Hij deed het twee slagen en daarna niet meer.

Zodra ik F1 en F2 op een andere tijd zet (de ene direct "aan", de tweede na 2 seconden "aan", werkt het prima. Zodra ik F1 en F2 tegelijk laat aansturen werkt het niet.

Ik zie in de logging dat alle drie de functie wel (tegelijk!) aangestuurd worden.

Meine

Website: http://www.EenOpZevenEnTachtig.nl
Ga naar bovenaan de pagina

phdirk

Netherlands
1762 Posts

Geplaatst - 21 jan 2016 :  21:20:13  Toon profiel  Reageer met citaat
Hallo Meine,

Dat het tegelijk niet werkt zou kunnen. Ik merk dat ook bij mijn Roco staalwagens, waarvan de huiven open en dicht gaan. Dat moet ook na elkaar gebeuren, want tegelijk lukt het niet en loopt de decoder vast. Kennelijk is het voor sommige decoders lastig twee uitgangen tegelijk te schakelen.


Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

Dieky

Netherlands
104 Posts

Geplaatst - 23 jan 2016 :  17:22:27  Toon profiel  Bezoek de homepagina van Dieky  Reageer met citaat
Ik ben vandaag even verder op onderzoek geweest.

Ik heb een ecos (zwart/wit)
als ik de ecos uitzet (lees: op stop druk) en de F, F1 en F2 aandoe en vervolgens de ecos weer aan doe (lees: op Go druk) blijft alles donker.
doe ik dit met 2 van de drie functie's gaan deze lampen wel aan.

conclusie: De ecos en/of mijn esu decoder kunnen niet meer dan twee veranderingen tegelijk aan. (F, F1 en F2)

Ik heb geen andere decoders waarbij zowel F als F1 en F2 aangesloten zijn. Dus ik kan niet testen of het aan de ecos ligt of aan de decoder (of beiden)

Meine

Website: http://www.EenOpZevenEnTachtig.nl
Ga naar bovenaan de pagina

Wim Ros

Netherlands
4700 Posts

Geplaatst - 23 jan 2016 :  20:49:03  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Dieky,

Nu wil ik hier best wel even een tipje van de sluier lichten.

De functies F0..F4 zijn samengesteld in 1 enkele opdracht via het protoctol wat er wordt gestuurd.

Dus met 1 opdracht kun ja alle 5 de functies aan of uitzetten, of een gedeelte aan of uit. Het zijn dus niet 5 aparte opdrachten alles gaat via 1 enkele opdracht. Wat je denkt zal niet van toepassing zijn ben ik bang.

Mvg
Wim.

Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

phdirk

Netherlands
1762 Posts

Geplaatst - 24 jan 2016 :  13:34:04  Toon profiel  Reageer met citaat
Hoi Wim,

Bedankt voor deze toelichting. Dat maakt veel duidelijk.

Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

Dieky

Netherlands
104 Posts

Geplaatst - 24 jan 2016 :  16:44:40  Toon profiel  Bezoek de homepagina van Dieky  Reageer met citaat
quote:
Oorspronkelijk geplaatst door Wim Ros

. Wat je denkt zal niet van toepassing zijn ben ik bang.



Wim,

Ik denk helemaal niks. Van programmeren, de decoders of de Ecos heb ik inhoudelijk geen verstand.
Ik constateer alleen dat het zo is, zoals als ik omschreven heb.

Ondertussen heb ik het "probleem" opgelost door de tijden te veranderen.

Wel ben ik benieuwd of ik de enige ben die dit kan "naspelen" of dat er anderen zijn die hetzelfde constateren.

Meine

(edit: tekstuele aanpassingen)

Website: http://www.EenOpZevenEnTachtig.nl

Bewerkt door Dieky op 24 jan 2016 16:46:29
Ga naar bovenaan de pagina

Wim Ros

Netherlands
4700 Posts

Geplaatst - 25 jan 2016 :  11:37:56  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Meine, dit heeft helemaal niets met de ECoS of met Koploper te maken, dit ligt vast in het DCC of Motorola of LocoNet protocol.

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina
  Vorig onderwerp Onderwerp Volgend onderwerp  
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing Problemen bij het forum? Stuur een email. Conrad
Bestel hier en steun het forum!
© EKweb 2006
Ga naar begin van deze pagina