Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 113 / Bezoekers Vandaag: 3251
Hoogste aantal aktieve gebruikers: 114
Google


Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Modelspoorwijzer.net

 Alle forums
 Koploper
 Gevorderden
 Speciale Actie Rijwindow aansturen
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Auteur Vorig onderwerp Onderwerp Volgend onderwerp  

JackvdW

Netherlands
266 berichten

Geplaatst - 08 apr 2015 :  01:38:49  Toon profiel  Reageer met citaat
Hallo allemaal,

Ik heb een probleempje met de aansturing van het Rijwindow met een Speciale Actie.

Wat ik wil bereiken is heel simpel: Een stilstaande handmatig rijdende loc met voorwaartse richting moet een aantal cm achterwaarts rijden.

Wat heb ik gemaakt: Speciale Actie die de rijrichting op achteruit zet en snelheidsstap 5 naar de desbetreffende loc stuurt. Aansturing: Schakelaar in het Baanontwerp met een Logische Actie.

Wat gebeurt er: (logging scherm) De loc wisselt wel de rijrichting maar begint achterwaart te rijden met Stap 1 en versneld niet verder.

Hierna zet ik de loc met het rijwindow stil (schuifje even heen en weer). De richting laat ik achterwaarts staan. Schakelaar zet ik uit.

Geeft ik de Speciale Actie nogmaals een aansturing springt de snelheid in n keer naar stap 5.

Ik zet de loc weer stil met het Rijwindow. De richting blijft achterwaarts staan. Schakelaar weer uit.

Geeft ik de speciale Actie nogmaals een aansturing dan loopt de snelheid langzaam (volgens massa gedrag) op van stap 1 naar 2, naar 3, 4 en 5. Dit is wat ik eigenlijk verwachtte bij de eerste keer aansturen.

Wat ik al uitgevonden heb is dat de rijrichtingswissel veroorzaakt dat de snelheid niet verder gaat dan stap 1. Zodra de richting van de loc in het rijwindow al goed staat, wordt er wel versneld naar stap 5. Zet ik in het rijwindow handmatig de richting op voorwaarts dan blijft de snelheid bij stap 1 steken.

De sprong in n keer naar stap 5 treed alleen op als de loc net uit het Automatisch Verkeer komt of wanneer hij net in het blok is geplaatst en nog niet heeft gereden en ik voor de tweede keer de Speciale Actie aanstuur en de eerste aansturing de richting heeft gewisseld.

Ik hoop dat iemand dit ook kan reproduceren, ik rij met een TC en Loconet maar ik zie het al in de logging fout gaan dus zal het daar wel niet aan liggen.

De uiteindelijke bediening is een Sequens die de loc ook weer stopt en de schakelaar een reset geeft, hierin is het euvel ook wel op te lossen maar ik wilde het hier toch melden.

Vast bedankt,

Groeten Jack.


Bewerkt door JackvdW op 08 apr 2015 02:07:57

hubertus

Netherlands
1161 Posts

Geplaatst - 13 apr 2015 :  11:20:23  Toon profiel  Reageer met citaat
Geen idee. Ik heb het eens nagespeeld en bij mij gaat het in de logging wel goed.
Zet anders even je database hier neer, misschien is daar nog wat aan te zien.

Huub
Ga naar bovenaan de pagina

JackvdW

Netherlands
266 Posts

Geplaatst - 14 apr 2015 :  17:02:22  Toon profiel  Reageer met citaat
Hoi Huub,

Bedankt voor je reactie.

Ik heb het momenteel al weer uit de database gehaald, maar ik zal het deze week even opnieuw in voeren. Zet de database daarna wel op het forum.

Als ik er trouwens twee losse Speciale Acties van maak (1e draait de richting, 2e snelheidsstap 5, beide aangestuurd met dezelfde Logische Actie) werkt het wel direct altijd goed.
Het kan daarna in een Sequens dan ook goed functioneren.

Groeten Jack.




Ga naar bovenaan de pagina

JackvdW

Netherlands
266 Posts

Geplaatst - 15 apr 2015 :  23:11:47  Toon profiel  Reageer met citaat
Hoi Huub,

Bijgaande database van mijn testbaantje.

De bedienende schakelaar staat rechts onderaan en het gaat om de BR155 loc.

Groet Jack.




Download Attachment: Testbaan1.bck
273,4 KB

Bewerkt door JackvdW op 16 apr 2015 02:09:19
Ga naar bovenaan de pagina

JackvdW

Netherlands
266 Posts

Geplaatst - 16 apr 2015 :  02:25:35  Toon profiel  Reageer met citaat
Hoi Huub,

Net even mijn database hier terug ingeladen en in simulatie laten draaien.

Het probleem treed dan NIET op dus testen heeft geen zin.

Zodra ik het weer op de baan probeer is het wel weer fout.

Geen idee waardoor dat nu komt, misschien toch het Loconet, maar ik heb inmiddels een work around.

Nog bedankt voor het testen.

Groeten Jack.

Bewerkt door JackvdW op 16 apr 2015 02:28:00
Ga naar bovenaan de pagina

Wim Ros

Netherlands
4697 Posts

Geplaatst - 16 apr 2015 :  09:18:11  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
quote:
Oorspronkelijk geplaatst door JackvdW

Hoi Huub,

Geen idee waardoor dat nu komt, misschien toch het Loconet, maar ik heb inmiddels een work around.



Uitgesloten!!!!!



Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

Wim Ros

Netherlands
4697 Posts

Geplaatst - 16 apr 2015 :  09:44:18  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Beste Jack,

Hier net even je test database laten werken.

Loc 155 op de baan gezet. Rijrichting vooruit, schakelaar aangezet. Rijrichting naar achteruit en snelheid loopt stapsgewijs op naar 5.
Loc stoppen met rijwindow slider te klikken snelheid loopt stapsgewijs naar 0. Richting is achteruit.

Rijrichting naar vooruit schakelaar aan, hetzelfde beeld, zoals je het bedoeld heb. M.A.W. het werkt.

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

JackvdW

Netherlands
266 Posts

Geplaatst - 16 apr 2015 :  10:59:57  Toon profiel  Reageer met citaat
Ha die Wim,

Het klopt wat je ziet in simulatie. Dat werkt bij mij ook

Maar schakel ik de communicatie naar de TC weer in dan rijdt de BR155 met stap 1 naar achter i.p.v. stap 5 (ook in de logging). Schakel ik de schakelaar uit en weer aan dan komt er in de logging een regeltje bij met Stap 5.
Staat de loc echter al in de achterwaartse richting en ik druk op de schakelaar dan komen in de logging keurig al de stappen langs zoals jij ze ook in simulatie ziet, dus volgens het massa gedrag. Blijft vreemd.

Bedank voor het controleren.

Groeten Jack.
Ga naar bovenaan de pagina

Wim Ros

Netherlands
4697 Posts

Geplaatst - 16 apr 2015 :  12:19:44  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Jack,

Dit was niet in simulatie, maar gewoon live via de centrale en Loconet.
En dat werkt gewoon.

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus



Download Attachment: Testbaan1jackvdw_20150416_122451.txt
2,28 KB



Download Attachment: Testbaan1jackvdw_spec_20150416_122321.txt
5,04 KB

Bewerkt door Wim Ros op 16 apr 2015 12:30:51
Ga naar bovenaan de pagina

JackvdW

Netherlands
266 Posts

Geplaatst - 16 apr 2015 :  21:55:40  Toon profiel  Reageer met citaat
Hoi Wim,

En dit maakt mijn Logging er van als de communicatie naar de TC aan staat.

PC: Windows7 64, Rosoft Loconet interface, TC met softwareversie 2.

Groeten Jack.



Download Attachment: Logging1.jpg
114,32KB



Download Attachment: Logging2.jpg
92,48KB

Bewerkt door JackvdW op 16 apr 2015 21:56:05
Ga naar bovenaan de pagina

Wim Ros

Netherlands
4697 Posts

Geplaatst - 16 apr 2015 :  23:54:12  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Beste Jack,

Had een beetje vals gespeeld, ik had het met een Z21 getest, en dan gaat het dus zonder problemen, net even met een Intellibox dezelfde test gedaan, en dan gaat het inderdaad niet goed.
De op lossing zit hem in het zetten van een vinkje.
Eigenlijk is het een bug in koploper maar dat is een ander verhaal.
Workaround is de volgende.


Groetjes


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

JackvdW

Netherlands
266 Posts

Geplaatst - 17 apr 2015 :  14:00:03  Toon profiel  Reageer met citaat
Hoi Wim,

Dat was hem dus.
Het gaat nu altijd goed.

Bedankt.

Groeten Jack.
Ga naar bovenaan de pagina
  Vorig onderwerp Onderwerp Volgend onderwerp  
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing Problemen bij het forum? Stuur een email. Conrad
Bestel hier en steun het forum!
© EKweb 2006
Ga naar begin van deze pagina